Commit fb77427d authored by Langhammer, Jens's avatar Langhammer, Jens

new release: 0.7.0rc1

parent 27d3aeda
Pipeline #3928 failed with stages
in 8 minutes and 38 seconds
[bumpversion]
current_version = 0.6.6
current_version = 0.7.0rc1
tag = True
commit = True
parse = (?P<major>\d+)\.(?P<minor>\d+)\.(?P<patch>\d+)(-?)(?P<release>.*)
serialize =
{major}.{minor}.{patch}-{release}
{major}.{minor}.{patch}
serialize =
{major}.{minor}.{patch}-{release}
{major}.{minor}.{patch}
message = new release: {new_version}
tag_name = version/{new_version}
......@@ -24,3 +24,4 @@ tag_name = version/{new_version}
[bumpversion:file:tier0/internal/version.go]
[bumpversion:file:p2/ui/nginx.conf]
......@@ -26,7 +26,7 @@ create-build-image:
before_script:
- echo "{\"auths\":{\"docker.beryju.org\":{\"auth\":\"$DOCKER_AUTH\"}}}" > /kaniko/.docker/config.json
script:
- /kaniko/executor --context $CI_PROJECT_DIR --dockerfile $CI_PROJECT_DIR/Dockerfile.build-base --destination docker.beryju.org/p2/build-base:latest --destination docker.beryju.org/p2/build-base:0.6.6
- /kaniko/executor --context $CI_PROJECT_DIR --dockerfile $CI_PROJECT_DIR/Dockerfile.build-base --destination docker.beryju.org/p2/build-base:latest --destination docker.beryju.org/p2/build-base:0.7.0-rc1
stage: build-build-image
only:
refs:
......@@ -80,7 +80,7 @@ build-p2-server:
before_script:
- echo "{\"auths\":{\"docker.beryju.org\":{\"auth\":\"$DOCKER_AUTH\"}}}" > /kaniko/.docker/config.json
script:
- /kaniko/executor --context $CI_PROJECT_DIR --dockerfile $CI_PROJECT_DIR/Dockerfile --destination docker.beryju.org/p2/server:latest --destination docker.beryju.org/p2/server:0.6.6
- /kaniko/executor --context $CI_PROJECT_DIR --dockerfile $CI_PROJECT_DIR/Dockerfile --destination docker.beryju.org/p2/server:latest --destination docker.beryju.org/p2/server:0.7.0-rc1
only:
- tags
- /^version/.*$/
......@@ -92,7 +92,7 @@ build-p2-static:
before_script:
- echo "{\"auths\":{\"docker.beryju.org\":{\"auth\":\"$DOCKER_AUTH\"}}}" > /kaniko/.docker/config.json
script:
- /kaniko/executor --context $CI_PROJECT_DIR --dockerfile $CI_PROJECT_DIR/Dockerfile.static --destination docker.beryju.org/p2/static:latest --destination docker.beryju.org/p2/static:0.6.6
- /kaniko/executor --context $CI_PROJECT_DIR --dockerfile $CI_PROJECT_DIR/Dockerfile.static --destination docker.beryju.org/p2/static:latest --destination docker.beryju.org/p2/static:0.7.0-rc1
only:
- tags
- /^version/.*$/
......@@ -104,7 +104,7 @@ build-p2-tier0:
before_script:
- echo "{\"auths\":{\"docker.beryju.org\":{\"auth\":\"$DOCKER_AUTH\"}}}" > /kaniko/.docker/config.json
script:
- /kaniko/executor --context $CI_PROJECT_DIR/tier0 --dockerfile $CI_PROJECT_DIR/tier0/Dockerfile --destination docker.beryju.org/p2/tier0:latest --destination docker.beryju.org/p2/tier0:0.6.6
- /kaniko/executor --context $CI_PROJECT_DIR/tier0 --dockerfile $CI_PROJECT_DIR/tier0/Dockerfile --destination docker.beryju.org/p2/tier0:latest --destination docker.beryju.org/p2/tier0:0.7.0-rc1
only:
- tags
- /^version/.*$/
......
apiVersion: v1
appVersion: "0.6.6"
appVersion: "0.7.0-rc1"
description: A Helm chart for p2.
name: p2
version: 0.6.6
version: 0.7.0-rc1
icon: https://p2.beryju.org/images/logo.png
# Default values for p2.
image:
tag: 0.6.6
tag: 0.7.0-rc1
config:
# Optionally specify fixed secret_key, otherwise generated automatically
......
......@@ -9,7 +9,7 @@
# - LE_MAIL: Optional; Let's Encrypt E-Mail. If this is not set, Let's Encrypt is not enabled.
K3S_VERSION="0.6.1"
P2_VERSION="0.6.6"
P2_VERSION="0.7.0-rc1"
export INSTALL_K3S_EXEC="--docker --no-deploy traefik"
if [ "$EUID" -ne 0 ]; then
......
......@@ -5,7 +5,7 @@ metadata:
name: p2
namespace: kube-system
spec:
chart: https://docker.beryju.org/chartrepo/p2/charts/p2-0.6.6.tgz
chart: https://docker.beryju.org/chartrepo/p2/charts/p2-0.7.0-rc1.tgz
targetNamespace: p2
valuesContent: |-
deployment:
......
"""p2 version header"""
__version__ = '0.6.6'
__version__ = '0.7.0-rc1'
......@@ -30,7 +30,7 @@ http {
gzip on;
gzip_types application/javascript image/* text/css;
gunzip on;
add_header X-p2-Version 0.6.6;
add_header X-p2-Version 0.7.0-rc1;
add_header Vary X-p2-Version;
root /static/;
......
package internal
const Version = "0.6.6"
const Version = "0.7.0-rc1"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment