Commit 41984d51 authored by Jens Langhammer's avatar Jens Langhammer

Initial commit

parents
*.gem
*.rbc
/.config
/coverage/
/InstalledFiles
/pkg/
/spec/reports/
/spec/examples.txt
/test/tmp/
/test/version_tmp/
/tmp/
# Used by dotenv library to load environment variables.
# .env
## Specific to RubyMotion:
.dat*
.repl_history
build/
*.bridgesupport
build-iPhoneOS/
build-iPhoneSimulator/
## Specific to RubyMotion (use of CocoaPods):
#
# We recommend against adding the Pods directory to your .gitignore. However
# you should judge for yourself, the pros and cons are mentioned at:
# https://guides.cocoapods.org/using/using-cocoapods.html#should-i-check-the-pods-directory-into-source-control
#
# vendor/Pods/
## Documentation cache and generated files:
/.yardoc/
/_yardoc/
/rdoc/
## Environment normalization:
/.bundle/
/vendor/bundle
/lib/bundler/man/
# for a library or gem, you might want to ignore these files since the code is
# intended to run in multiple environments; otherwise, check them in:
# Gemfile.lock
# .ruby-version
# .ruby-gemset
# unless supporting rvm < 1.11.0 or doing something fancy, ignore this:
.rvmrc
doc/*
--markup-provider=redcarpet
--markup=markdown
source 'https://rubygems.org'
gem 'rake'
gem 'puppet'
gem 'puppet-lint'
gem 'puppet-syntax'
gem 'git'
gem 'net-ssh'
gem 'logger-colors', '~> 1.0'
gem 'puppet-strings'
gem 'yard'
gem 'redcarpet'
gem 'github-markup'
gem 'apipie-bindings'
GEM
remote: https://rubygems.org/
specs:
CFPropertyList (2.2.8)
apipie-bindings (0.0.18)
json (>= 1.2.1)
oauth
rest-client (>= 1.6.5, < 3.0.0)
domain_name (0.5.20161021)
unf (>= 0.0.5, < 1.0.0)
facter (2.4.6)
CFPropertyList (~> 2.2.6)
git (1.3.0)
github-markup (1.4.0)
hiera (3.2.1)
http-cookie (1.0.3)
domain_name (~> 0.5)
json (2.0.2)
json_pure (1.8.3)
logger-colors (1.0.0)
mime-types (3.1)
mime-types-data (~> 3.2015)
mime-types-data (3.2016.0521)
net-ssh (3.2.0)
netrc (0.11.0)
oauth (0.5.1)
puppet (4.7.0)
CFPropertyList (~> 2.2.6)
facter (> 2.0, < 4)
hiera (>= 2.0, < 4)
json_pure (~> 1.8)
puppet-lint (2.0.2)
puppet-strings (0.99.0)
yard (~> 0.9.5)
puppet-syntax (2.1.1)
rake
rake (11.3.0)
redcarpet (3.3.4)
rest-client (2.0.0)
http-cookie (>= 1.0.2, < 2.0)
mime-types (>= 1.16, < 4.0)
netrc (~> 0.8)
unf (0.1.4)
unf_ext
unf_ext (0.0.7.2)
yard (0.9.5)
PLATFORMS
ruby
DEPENDENCIES
apipie-bindings
git
github-markup
logger-colors (~> 1.0)
net-ssh
puppet
puppet-lint
puppet-strings
puppet-syntax
rake
redcarpet
yard
# BeryJu.org Puppet Module Template
## Commands
`bundle` - Install necessary dependencies
`rake` - Run Syntax checks
require 'rake'
require 'puppet-syntax/tasks/puppet-syntax'
require 'puppet-lint/tasks/puppet-lint'
require 'puppet-strings/tasks/generate'
# disable this because we clone into `puppet-beryjuorg`
PuppetLint.configuration.send('disable_autoloader_layout')
# sigh
PuppetLint.configuration.send('disable_140chars')
task :default => [
Rake::Task['syntax'],
Rake::Task['lint'],
Rake::Task['strings:generate']
]
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment